Issue with our SIP Trunk Cluster CL1

Incident Report for I.T Communications Limited

Resolved

This was just a cosmetic display bug following a recent update. No customer calls were affected by this.
Posted Jun 19, 2026 - 12:26 BST

Investigating

We are aware of a issue on SIP CL1 Cluster which may prevent some customers from making calls

Our developer is looking into the issue. update to follow.
Posted Jun 19, 2026 - 12:02 BST
This incident affected: SIP Trunk Cluster CL1 (SIP Trunking - SIP-01.it-communicationsltd.co.uk, SIP Trunking - SIP-02.it-communicationsltd.co.uk, SIP Trunking - SIP-03.it-communicationsltd.co.uk).