CRM and Support Desk - Down

Incident Report for I.T Communications Limited

Resolved

Issue seem resolved.
Posted Nov 03, 2025 - 10:49 GMT

Monitoring

We are not able to access support tickets or our CRM today due to a issue with our CRM Provider "ZoHo" so their might be a delay in replying to tickets.
Posted Nov 03, 2025 - 09:39 GMT