Power Issue at Sov Hose DC - Sovereign House, 227 Marsh Wall, London E14 9SD
Incident Report for I.T Communications Limited
Resolved
One of the power feeds had tripped. This has now been reset and full power restored.
Posted Nov 07, 2024 - 17:41 GMT
Update
Staff are now looking into the issue on the 2nd Floor.
Posted Nov 07, 2024 - 17:33 GMT
Investigating
We have lost one of our Power Feeds to our primary rack at Sovereign House.

There should be no impact to customer services due to all our servers being dual power fed.

We have made contact with the Data Centre and we are working with them to resolve the issue.
Posted Nov 07, 2024 - 17:22 GMT