Microsoft 365 Exchange Email Issues

Incident Report for I.T Communications Limited

Resolved

This incident has been resolved.
Posted May 16, 2025 - 09:36 BST

Update

Looks like Microsoft has this morning fixed the issues with their exchange servers and our initial test shows we are now getting 100% of the emails sent to our support desk.
Posted May 16, 2025 - 09:31 BST

Update

We are continuing to monitor for any further issues.
Posted May 14, 2025 - 07:13 BST

Monitoring

Microsoft are having issues with 365 Exchange Email forwarding. This is causing some emails to not reach our support desk.

We have turned on Automatic Reply on our support tickets, If you do not get an automatic response, this means we may not have received your email.

You can also submit tickets or provide updates to existing tickets directly by going to https://support.it-communicationsltd.co.uk/portal/en/signin
Posted May 14, 2025 - 07:10 BST
This incident affected: Other Services (Microsoft 366 Exchange Emails).