Intermittent issue with some inbound calls

Incident Report for I.T Communications Limited

Resolved

The issue with inbound calls appears to be cleared.
Posted May 02, 2025 - 16:22 BST

Investigating

One of our carriers reported Intermittent issue with some inbound calls which is causing some calls to fail and not route to our network.

Not all customers will be affected by this issue.
Posted May 02, 2025 - 16:12 BST
This incident affected: VoIP Calls (Inbound Calling).