Web Browser Access not working from DSL Internet Connections

Incident Report for I.T Communications Limited

Resolved

Hi,

The issue is now fully resolved.
Posted Jan 14, 2025 - 10:01 GMT

Investigating

We are aware that some customers are not able to browse the internet.

We believe that we have found the issue and putting in a fix to resolve. Update to folllow.
Posted Jan 14, 2025 - 09:49 GMT
This incident affected: Customer Internet Access (DSL Broadband Network).