Outbound Calls Failing
Incident Report for I.T Communications Limited
Resolved
We have completed tests and all looks fine now. We have therefore restored original call routing
Posted Nov 29, 2017 - 17:48 GMT
Identified
We have received an update from the affected carrier to say the issue is now resolved.

We will continue to leave the calls routed away until we have fully tested and confirmed this to be the case.
Posted Nov 29, 2017 - 15:13 GMT
Investigating
We have been notified by some customers outbound calls are failing. We have looked at the logs and it appears one of our carriers is having issues. We are now in the process of re-routing outbound calls away from the provider.
Posted Nov 29, 2017 - 15:03 GMT