Mobile Networks and UK Broadband Issues
Incident Report for I.T Communications Limited
Resolved
This incident has been resolved.
Posted Mar 30, 2020 - 14:01 BST
Monitoring
Due to more people working from home due to the Corona Virus Outbreak, it would appear this is butting extream presure on ISP's

We have had reports that some of you cannot call Mobile's and some have also reported issues with their broandband providers whereby the internet is slow.

Calls from VoIP to Mobile, Mobile to Mobile is also likely to fail.

I would like to remind you that this is outside of our network and our control.

Please take a look at the below link.

https://www.thesun.co.uk/money/11190026/o2-virgin-tesco-ee-three-and-giffgaff-down-as-customers-struggle-to-use-broadband-and-mobiles/?utm_medium=Social&utm_campaign=fabulousfacebook&utm_source=Facebook#Echobox=1584442824
Posted Mar 17, 2020 - 11:32 GMT