Inbound Calls
Incident Report for I.T Communications Limited
Resolved
Our carrier believe they have now isolated the fault and service is fully restored. If you have any further issues after 17:40 please let us know by emailing support.

We will carry out a full investigation as to the cause of this issue and send an update as soon as that is available.
 

We apologise for the inconvenience this has caused
Posted Sep 20, 2017 - 17:40 BST
Update
Our Carrier believe they may have isolated the fault and are now working on a resolution. We hope to be able to send a positive update very shortly.
Posted Sep 20, 2017 - 16:56 BST
Update
This is a issue with one of our carriers and is affecting not only us but a very large number of other VoIP Providers within the UK.

We are in contact with the carrier to understand the issue.
Posted Sep 20, 2017 - 16:27 BST
Update
Our engineers continue to investigate the ongoing calling issues which appear to be affecting inbound and some outbound calls through our network, we do not yet have any further detail to share but will send a further update shortly
Posted Sep 20, 2017 - 16:22 BST
Investigating
We are aware of reports of a problem with some calls to numbers on the network, our team are currently investigating and we will update you shortly.
Posted Sep 20, 2017 - 16:10 BST