Reports of Some Inbound Calls Not Workig
Incident Report for I.T Communications Limited
Resolved
At approximately 09:00 one of our Inbound Carriers suffered a major DNS failure of both their primary and secondary systems. After normal DNS caching delays this caused all customers sending IP calls into their network using DNS names to suffer problems. IP address based calling, TDM features and calls from their network were not affected. The issue was fully cleared around 9.18 their team have now completed preliminary analysis of the outage and identified a software vulnerability that has previously gone undetected.

Clearly the impact of this vulnerability was serious and unacceptable therefore they can confirm that their senior team are taking immediate steps to review all associated systems and implement any fixes that are necessary to protect us going forward.

This would not have affected all customers.

Please accept our sincere apologies for the disruption to service.
Posted Jan 17, 2019 - 12:48 GMT
Identified
Update from the affected inbound carrier.

"We are aware of a serious outage on our network this morning that has now been resolved. The team are carrying out a full investigation into the underlying cause and we will update again as soon as we have further information."
Posted Jan 17, 2019 - 09:33 GMT
Investigating
We have been advised from one of our Inbound Carriers that they are experencing an issue at the moment which is preventing some inbound calls from reaching our network.

We will provide an update ASAP.
Posted Jan 17, 2019 - 09:28 GMT
This incident affected: VoIP Calls (Inbound Calling).